using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*/(?:add-review|reviews)/$)listing/(.+?)/([^\/.]+)/?(reviews/?(.+?)?/?)?/?$";
string input = @"listing/united-states/postname/
listing/united-states/california/postname/
listing/united-states/california/chino/postname/
listing/united-states/california/chino/postname/reviews/testreview/
listing/united-states/california/chino/postname1/reviews/
listing/united-states/california/chino/postname2/add-review/
listing/united-states/california/chino/postname1/review/
listing/united-states/california/chino/postname2/add-reviews/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}