use strict;
my $str = 'listing/united-states/postname/
listing/united-states/california/postname/
listing/united-states/california/chino/postname/
listing/united-states/california/chino/postname/reviews/testreview/
listing/united-states/california/chino/postname1/reviews/
listing/united-states/california/chino/postname2/add-review/
listing/united-states/california/chino/postname1/review/
listing/united-states/california/chino/postname2/add-reviews/';
my $regex = qr~(?!.*/(?:add-review|reviews)/$)listing/(.+?)/([^\/.]+)/?(reviews/?(.+?)?/?)?/?$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}