import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!.*/(?:add-review|reviews)/$)listing/(.+?)/([^\\/.]+)/?(reviews/?(.+?)?/?)?/?$";
final String string = "listing/united-states/postname/\n"
+ "listing/united-states/california/postname/\n"
+ "listing/united-states/california/chino/postname/\n"
+ "listing/united-states/california/chino/postname/reviews/testreview/\n\n"
+ "listing/united-states/california/chino/postname1/reviews/\n\n"
+ "listing/united-states/california/chino/postname2/add-review/\n\n"
+ "listing/united-states/california/chino/postname1/review/\n\n"
+ "listing/united-states/california/chino/postname2/add-reviews/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}