$re = '~(?!.*/(?:add-review|reviews)/$)listing/(.+?)/([^\/.]+)/?(reviews/?(.+?)?/?)?/?$~m';
$str = 'listing/united-states/postname/
listing/united-states/california/postname/
listing/united-states/california/chino/postname/
listing/united-states/california/chino/postname/reviews/testreview/
listing/united-states/california/chino/postname1/reviews/
listing/united-states/california/chino/postname2/add-review/
listing/united-states/california/chino/postname1/review/
listing/united-states/california/chino/postname2/add-reviews/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);