#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.(\w+)\((.*?)\)(?=\.|$|;)"
Local $sString = ".replace("hello", "world").trim().replace("chicken", "fried").upper()" & @CRLF & _
".replace(/(test)/g, "").trim().replace("", "").upper()" & @CRLF & _
".trim()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")