re = /\.(\w+)\((.*?)\)(?=\.|$|;)/m
str = '.replace("hello", "world").trim().replace("chicken", "fried").upper()
.replace(/(test)/g, "").trim().replace("", "").upper()
.trim()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end