using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(\w+)\((.*?)\)(?=\.|$|;)";
string input = @".replace(""hello"", ""world"").trim().replace(""chicken"", ""fried"").upper()
.replace(/(test)/g, "").trim().replace("", "").upper()
.trim()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}