$re = '/\.(\w+)\((.*?)\)(?=\.|$|;)/m';
$str = '.replace("hello", "world").trim().replace("chicken", "fried").upper()
.replace(/(test)/g, "").trim().replace("", "").upper()
.trim()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);