using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?-[^-\n]+-\K.*?(?=-|$)";
string input = @"order_no ingredients
1 cheese-olives-peppers-olives
2 cheese-olives
3 cheese-tomatoes-olives
4 cheese";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}