$re = '/^.*?-[^-\n]+-\K.*?(?=-|$)/m';
$str = 'order_no ingredients
1 cheese-olives-peppers-olives
2 cheese-olives
3 cheese-tomatoes-olives
4 cheese';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);