re = /^.*?-[^-\n]+-\K.*?(?=-|$)/m
str = 'order_no ingredients
1 cheese-olives-peppers-olives
2 cheese-olives
3 cheese-tomatoes-olives
4 cheese'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end