import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?-[^-\\n]+-\\K.*?(?=-|$)";
final String string = "order_no ingredients\n"
+ " 1 cheese-olives-peppers-olives\n"
+ " 2 cheese-olives\n"
+ " 3 cheese-tomatoes-olives\n"
+ " 4 cheese";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}