re = /([^.]*)\">$/m
str = '$this$ $is$ $a$ ytreh.test">
<GuiSettings Plugin="Questions.Tab.Tab">
<GuiSettings Plugin="AlteryxGuiToolkit.Questions.Tab.Tab">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end