using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<br><i>)[^<\/i>](.*?)(?=<\/i><br>)";
string input = @"<br><i>d2dded</i><br><br><i>d2dded</i><br>
<br><i>""Não pisoteie quando subir as escadas - sua irmã está dormindo.""</i><br>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}