import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<br><i>)[^<\\/i>](.*?)(?=<\\/i><br>)";
final String string = "<br><i>d2dded</i><br><br><i>d2dded</i><br>\n"
+ "<br><i>\"Não pisoteie quando subir as escadas - sua irmã está dormindo.\"</i><br>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}