const regex = /(?<=<br><i>)[^<\/i>](.*?)(?=<\/i><br>)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<br><i>)[^<\\\/i>](.*?)(?=<\\\/i><br>)', 'gi')
const str = `<br><i>d2dded</i><br><br><i>d2dded</i><br>
<br><i>"Não pisoteie quando subir as escadas - sua irmã está dormindo."</i><br>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}