$re = '/(?<=<br><i>)[^<\/i>](.*?)(?=<\/i><br>)/i';
$str = '<br><i>d2dded</i><br><br><i>d2dded</i><br>
<br><i>"Não pisoteie quando subir as escadas - sua irmã está dormindo."</i><br>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);