using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\b[A-Z]\.)(?<!\w\.\w)(?<![A-Z][a-z]\.)(?<=[.?])\s";
string input = @"Mr. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.
C. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}