re = /(?<!\b[A-Z]\.)(?<!\w\.\w)(?<![A-Z][a-z]\.)(?<=[.?])\s/m
str = 'Mr. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.
C. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end