$re = '/(?<!\b[A-Z]\.)(?<!\w\.\w)(?<![A-Z][a-z]\.)(?<=[.?])\s/m';
$str = 'Mr. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.
C. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);