import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\b[A-Z]\\.)(?<!\\w\\.\\w)(?<![A-Z][a-z]\\.)(?<=[.?])\\s";
final String string = "Mr. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.\n\n"
+ "C. Daniel, who love cakes, is taking a trip to Nevada. Not gonna lie, i would go as well.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}