using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^?=&]+)(=([^&]*))?";
string input = @"Signature Algorithm=ecdsa-with-SHA256&Not Before=Jul 23 00:00:002018 GMT&Not After=Jul 19 00:00:00 2033 GMT";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}