re = /([^?=&]+)(=([^&]*))?/m
str = 'Signature Algorithm=ecdsa-with-SHA256&Not Before=Jul 23 00:00:002018 GMT&Not After=Jul 19 00:00:00 2033 GMT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end