import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^?=&]+)(=([^&]*))?";
final String string = "Signature Algorithm=ecdsa-with-SHA256&Not Before=Jul 23 00:00:002018 GMT&Not After=Jul 19 00:00:00 2033 GMT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}