const regex = /<img.+src=['"](?P<src>.+?)['"].*>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.+src=[\'"](?P<src>.+?)[\'"].*>', 'i')
const str = `<img class="fr-draggable fr-fil fr-dii" src="//website.com/admin/img/uploads/wysiwyg/ORG_1475303208-troubador1.png" style="width: 300px;" alt="">Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nulla vehicula ligula vitae malesuada mollis. Donec tristique augue ut ipsum lacinia rhoncus. Donec a massa ut urna euismod imperdiet. Integer porta efficitur mollis. Vivamus mollis elementum placerat. Praesent viverra felis sem, at fringilla nulla semper ac. Nunc augue velit, tincidunt sed feugiat quis, dapibus eu est. Duis quis varius quam. Nullam quis ultrices lectus.<img class="fr-draggable fr-fir fr-dii" src="//website.com/admin/img/uploads/wysiwyg/ORG_1475303256-troubador2.png" style="width: 300px;"><strong>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nulla vehicula ligula vitae malesuada mollis. Donec tristique augue ut ipsum lacinia rhoncus. Donec a massa ut urna euismod imperdiet. Integer porta efficitur mollis. Vivamus mollis elementum placerat. Praesent viverra felis sem, at fringilla nulla semper ac. Nunc augue velit, tincidunt sed feugiat quis, dapibus eu est. Duis quis varius quam. Nullam quis ultrices lectus.</strong>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}