import re
regex = re.compile(r"<img.+src=['\"](?P<src>.+?)['\"].*>", flags=re.IGNORECASE)
test_str = "<img class=\"fr-draggable fr-fil fr-dii\" src=\"//website.com/admin/img/uploads/wysiwyg/ORG_1475303208-troubador1.png\" style=\"width: 300px;\" alt=\"\">Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nulla vehicula ligula vitae malesuada mollis. Donec tristique augue ut ipsum lacinia rhoncus. Donec a massa ut urna euismod imperdiet. Integer porta efficitur mollis. Vivamus mollis elementum placerat. Praesent viverra felis sem, at fringilla nulla semper ac. Nunc augue velit, tincidunt sed feugiat quis, dapibus eu est. Duis quis varius quam. Nullam quis ultrices lectus.<img class=\"fr-draggable fr-fir fr-dii\" src=\"//website.com/admin/img/uploads/wysiwyg/ORG_1475303256-troubador2.png\" style=\"width: 300px;\"><strong>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nulla vehicula ligula vitae malesuada mollis. Donec tristique augue ut ipsum lacinia rhoncus. Donec a massa ut urna euismod imperdiet. Integer porta efficitur mollis. Vivamus mollis elementum placerat. Praesent viverra felis sem, at fringilla nulla semper ac. Nunc augue velit, tincidunt sed feugiat quis, dapibus eu est. Duis quis varius quam. Nullam quis ultrices lectus.</strong>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")