re = /<img.+src=['"](?P<src>.+?)['"].*>/i
str = '<img class="fr-draggable fr-fil fr-dii" src="//website.com/admin/img/uploads/wysiwyg/ORG_1475303208-troubador1.png" style="width: 300px;" alt="">Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nulla vehicula ligula vitae malesuada mollis. Donec tristique augue ut ipsum lacinia rhoncus. Donec a massa ut urna euismod imperdiet. Integer porta efficitur mollis. Vivamus mollis elementum placerat. Praesent viverra felis sem, at fringilla nulla semper ac. Nunc augue velit, tincidunt sed feugiat quis, dapibus eu est. Duis quis varius quam. Nullam quis ultrices lectus.<img class="fr-draggable fr-fir fr-dii" src="//website.com/admin/img/uploads/wysiwyg/ORG_1475303256-troubador2.png" style="width: 300px;"><strong>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nulla vehicula ligula vitae malesuada mollis. Donec tristique augue ut ipsum lacinia rhoncus. Donec a massa ut urna euismod imperdiet. Integer porta efficitur mollis. Vivamus mollis elementum placerat. Praesent viverra felis sem, at fringilla nulla semper ac. Nunc augue velit, tincidunt sed feugiat quis, dapibus eu est. Duis quis varius quam. Nullam quis ultrices lectus.</strong>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end