using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!(?:[ab]*c){1,2}[ab]*\b)(?=(?:[bc]*a){3})(?:[ac]*b){3}[abc]*\b";
string input = @"aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbbc
aabbb
abbccc
abcabca
aaabbbc
aabbb
abbccc
abcabca ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}