re = /\b(?!(?:[ab]*c){1,2}[ab]*\b)(?=(?:[bc]*a){3})(?:[ac]*b){3}[abc]*\b/m
str = 'aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbbc
aabbb
abbccc
abcabca
aaabbbc
aabbb
abbccc
abcabca '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end