const regex = /\b(?!(?:[ab]*c){1,2}[ab]*\b)(?=(?:[bc]*a){3})(?:[ac]*b){3}[abc]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:[ab]*c){1,2}[ab]*\\b)(?=(?:[bc]*a){3})(?:[ac]*b){3}[abc]*\\b', 'gm')
const str = `aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
aaabbbc
aabbb
abbccc
abcabca
aaabbbc
aabbb
abbccc
abcabca `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}