import re
regex = re.compile(r"\b(?!(?:[ab]*c){1,2}[ab]*\b)(?=(?:[bc]*a){3})(?:[ac]*b){3}[abc]*\b", flags=re.MULTILINE)
test_str = ("aaabbb\n"
"ababab\n"
"aaabbbccc\n"
"abcabcabc\n"
"ababcabcc\n\n"
" aaabbb \n"
" ababab \n"
"aaabbbccc \n"
" abcabcabc \n"
" ababcabcc \n\n"
"aaabbbc\n"
"aabbb\n"
"abbccc\n"
"abcabca\n\n"
" aaabbbc \n"
" aabbb \n"
" abbccc \n"
" abcabca ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")