using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+?)(\ \((.*)\))*\ ([0-9\.]+)";
string input = @"fghhe dfg rt (jk) 456
rwersdfsdf 456
rertret (ghfg) 456";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}