re = /(.+?)(\ \((.*)\))*\ ([0-9\.]+)/
str = 'fghhe dfg rt (jk) 456
rwersdfsdf 456
rertret (ghfg) 456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end