$re = '/(.+?)(\ \((.*)\))*\ ([0-9\.]+)/';
$str = 'fghhe dfg rt (jk) 456
rwersdfsdf 456
rertret (ghfg) 456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);