package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+?)(\ \((.*)\))*\ ([0-9\.]+)`)
var str = `fghhe dfg rt (jk) 456
rwersdfsdf 456
rertret (ghfg) 456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}