#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![0])(([0-9]{1,10})|([0-9]{1,10}),[0-9]{2})$"
Local $sString = "1234567890" & @CRLF & _
"1234567890,00" & @CRLF & _
"1234567890,01" & @CRLF & _
"1234567890,99" & @CRLF & _
"0123456789" & @CRLF & _
"0123456789,12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")