use strict;
my $str = '1234567890
1234567890,00
1234567890,01
1234567890,99
0123456789
0123456789,12';
my $regex = qr/^(?![0])(([0-9]{1,10})|([0-9]{1,10}),[0-9]{2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}