$re = '/^(?![0])(([0-9]{1,10})|([0-9]{1,10}),[0-9]{2})$/m';
$str = '1234567890
1234567890,00
1234567890,01
1234567890,99
0123456789
0123456789,12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);