const regex = /^(?![0])(([0-9]{1,10})|([0-9]{1,10}),[0-9]{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![0])(([0-9]{1,10})|([0-9]{1,10}),[0-9]{2})$', 'gm')
const str = `1234567890
1234567890,00
1234567890,01
1234567890,99
0123456789
0123456789,12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}