#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<button[^>]*>\n\s*<span .*<\/span>\n\s*<\/button>"
Local $sString = " <button type="button" *ngIf="holerite.arquivo" class="btn btn-link btn-crud-list datalist-button"" & @CRLF & _
" (click)="download(holerite.arquivo)" [pTooltip]="'entity.action.download' | translate"" & @CRLF & _
" tooltipPosition="top">" & @CRLF & _
" <span class="fa fa-download fa-lg"></span>" & @CRLF & _
" </button>" & @CRLF & _
" <button type="button" class="btn btn-link btn-crud-list datalist-button" (click)="delete(holerite.id!)"" & @CRLF & _
" [pTooltip]="'entity.action.delete' | translate" tooltipPosition="top">" & @CRLF & _
" <span class="fa fa-trash fa-lg"></span>" & @CRLF & _
" </button>" & @CRLF & _
"<button>AAhhh</button>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")