const regex = /<button[^>]*>\n\s*<span .*<\/span>\n\s*<\/button>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<button[^>]*>\\n\\s*<span .*<\\\/span>\\n\\s*<\\\/button>', 'gm')
const str = ` <button type="button" *ngIf="holerite.arquivo" class="btn btn-link btn-crud-list datalist-button"
(click)="download(holerite.arquivo)" [pTooltip]="'entity.action.download' | translate"
tooltipPosition="top">
<span class="fa fa-download fa-lg"></span>
</button>
<button type="button" class="btn btn-link btn-crud-list datalist-button" (click)="delete(holerite.id!)"
[pTooltip]="'entity.action.delete' | translate" tooltipPosition="top">
<span class="fa fa-trash fa-lg"></span>
</button>
<button>AAhhh</button>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}