re = /<button[^>]*>\n\s*<span .*<\/span>\n\s*<\/button>/m
str = ' <button type="button" *ngIf="holerite.arquivo" class="btn btn-link btn-crud-list datalist-button"
(click)="download(holerite.arquivo)" [pTooltip]="\'entity.action.download\' | translate"
tooltipPosition="top">
<span class="fa fa-download fa-lg"></span>
</button>
<button type="button" class="btn btn-link btn-crud-list datalist-button" (click)="delete(holerite.id!)"
[pTooltip]="\'entity.action.delete\' | translate" tooltipPosition="top">
<span class="fa fa-trash fa-lg"></span>
</button>
<button>AAhhh</button>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end