import re
regex = re.compile(r"<button[^>]*>\n\s*<span .*<\/span>\n\s*<\/button>", flags=re.MULTILINE)
test_str = (" <button type=\"button\" *ngIf=\"holerite.arquivo\" class=\"btn btn-link btn-crud-list datalist-button\"\n"
" (click)=\"download(holerite.arquivo)\" [pTooltip]=\"'entity.action.download' | translate\"\n"
" tooltipPosition=\"top\">\n"
" <span class=\"fa fa-download fa-lg\"></span>\n"
" </button>\n"
" <button type=\"button\" class=\"btn btn-link btn-crud-list datalist-button\" (click)=\"delete(holerite.id!)\"\n"
" [pTooltip]=\"'entity.action.delete' | translate\" tooltipPosition=\"top\">\n"
" <span class=\"fa fa-trash fa-lg\"></span>\n"
" </button>\n"
"<button>AAhhh</button>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")