using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([2-9]\d|1[2-9]).\d{1,}|11.([2-9]|\d{2,}))(.\d+)*$";
string input = @"9.1
9.5
11.0
11.21
12.0
99.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}