re = /^(([2-9]\d|1[2-9]).\d{1,}|11.([2-9]|\d{2,}))(.\d+)*$/m
str = '9.1
9.5
11.0
11.21
12.0
99.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end