package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([2-9]\d|1[2-9]).\d{1,}|11.([2-9]|\d{2,}))(.\d+)*$`)
var str = `9.1
9.5
11.0
11.21
12.0
99.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}