const regex = /^(([2-9]\d|1[2-9]).\d{1,}|11.([2-9]|\d{2,}))(.\d+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([2-9]\\d|1[2-9]).\\d{1,}|11.([2-9]|\\d{2,}))(.\\d+)*$', 'gm')
const str = `9.1
9.5
11.0
11.21
12.0
99.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}