using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<section\b.*?>\K.*(?=<\/section>)";
string input = @"<section dsds dss >
dsdsds
= 7372732
""
' '
< >
<div fdfdf dsdd =""sd""><div fdfdf dsdd =""sd"">fdfd</div>fdfd</div>
ds
dsds dsds
ds dsdsds dsdsd
</section>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}