const regex = /<section\b.*?>\K.*(?=<\/section>)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<section\\b.*?>\\K.*(?=<\\\/section>)', 'gs')
const str = `<section dsds dss >
dsdsds
= 7372732
""
' '
< >
<div fdfdf dsdd ="sd"><div fdfdf dsdd ="sd">fdfd</div>fdfd</div>
ds
dsds dsds
ds dsdsds dsdsd
</section>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}