import Foundation
let pattern = #"<section\b.*?>\K.*(?=<\/section>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<section dsds dss >
dsdsds
= 7372732
""
' '
< >
<div fdfdf dsdd ="sd"><div fdfdf dsdd ="sd">fdfd</div>fdfd</div>
ds
dsds dsds
ds dsdsds dsdsd
</section>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)